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Opening an account 
 
To install the program, download the fxddwin.exe file. You will be required to open a demo 
account. 

 
 
The demo account registers your trading operations and allows you to work on your trading 
strategies. To open the demo account it is necessary to fill in all the fields. When registering 
you can choose the value of the leverage ('Leverage') and indicate the size of the initial 
deposit in the 'Deposit' field. You can choose the account type (the 'Account Type' field):  
•  Forex - open the demo account at FOREX;  
•  MiniForex - open a demo account to work at mini-Forex;  
 
You must also check the 'I accept to subscribe into your news letters' and select the 
'Register' button. 
 
In the case of successful demo account registration, the window with the login and password 
will appear. 



 
 
If a new demo account was not registered successfully, the message 'Can not allocate an 
account!' will appear. 

 
 
In this case, it is recommended to check your Internet connection and to check the client 
terminal options. You can open a demo account by selecting the 'Tools - > Options' menu, 

by key combination 'Ctrl-O' or by clicking the button : . 

 
 
The window will appear:  



 
 
Select 'Open an Account'. You can open an account from the 'Navigator' window by selecting 
the 'Accounts', by clicking the right mouse button and by selecting 'Open an Account' from 
the scroll-down menu.  

 
Server and account settings 

 
To set the client terminal you should select 'Tools - > Options' menu or by using the key 

combination 'Ctrl-O' or by clicking the button:  

 
 
Following window will appear:  



 
 
If you want to connect the client terminal to the server you should know the IP address or 
domain name of the WindowsTrader server. The connection to the server is made through port 
1950. It should be written "address: 1950" in the 'Server' field.  
When ticking 'Enable DDE' the quotes coming to WindowsTrader are translated outside 
through the dynamic data exchange protocol. You can see an example of the terminal use for 
MS Excel in the DDE Sample file (WindowsTrader program group).  
The account number (or login) and password should be indicated in the account settings. This 
information will be saved in your computer memory if you tick the 'Keep personal settings 
and data' option.  
 
Changing Password 
 

 
 
To change your password, you should enter the existing password and then enter your new 
password twice (to check the entry accuracy).  
 
You can also open a new account.  

Events setup 
 
The event setting specifies a special sound for each event (i.e., a audio file having the WAV 
extension or other file which can be performed in operation system). To disable the sound, 
delete the tick from the 'Play events' field.  



 
 

• Play events - notifications on/off;  
• Select - select the file to be notified;  
• Play - play the sound notification/run the notifying application.  

Authorization 
 
Authorization can be performed automatically by saving personal data. If personal data is not 
saved you will be asked to enter the login, password and server.  

 
 
Authorization can also be performed from the 'Navigator' window of the 'Accounts' menu 
allowing you to switch from one account to another.  

Market Watch 
 
The quotes window 'Market watch' is a service window along with the 'Navigator' window 
and with the 'Terminal'. This window can be enabled/disabled by pushing the key combination 

'Ctrl - M' from the main menu 'View - > Market Watch' or by clicking the button of the 
toolbar. 



 
 
The list of the instruments selected is placed in the 'Market Watch' window. This list may be 
empty at first. When clicking with the right mouse button the menu will appear where you can 
select the 'Show All Symbols' line. The quotes on these instruments will come in the 'bid; 
ask; high; low; time' format. To minimize the traffic you can exclude some instruments from 
your 'Market Watch' by selecting 'Hide Symbol' or by clicking the 'Del' button. In this case, 
the quotes will come only for the instruments selected. Open the chart window on the 
instrument you need ('Chart Window') from the contextual menu. When selecting the 'New 
Order' command either by clicking 'F9' or by double clicking the instrument selected, the form 
to expose the order will be shown.  
 
 

Navigator 



 
The 'Navigator' window is a service window along 
with the 'Market Watch' window and with the 
'Terminal'. This window can be enabled/disabled 
by using the key combination 'Ctrl - N' from the 
main menu 'View - > Navigator' or by clicking 

the button on the toolbar.  
The Navigator window allows to get a quick access 
to different functions of the program. There are 3 
groups in the window: 'Accounts', 'Indicators' and 
'Expert Advisors' which can be opened by clicking 
with the left mouse button at the '+' sign near the 
corresponding group. There is a list of the 
accessible client's accounts in the 'Accounts' 
group. Clicking with the right mouse button at the 
group will allow to open a new demo account. 
Double clicking with the left mouse button on one 
of the accessible accounts allows you to switch 
from one account to another one.  
 
 
There is a list of technical indicators available in 
the 'Indicators' group. You can add the selected 
indicator to the current chart by double clicking 
with the left mouse button. You can also insert 
indicators to the chart (or delete them from the 
chart) from the main menu ('Insert - > 
Indicators') or from the menu. 
 
The Expert Advisors group includes a list of the 
so-called 'Expert Advisors' available. The Expert 
Advisor is a program written in MetaQuotes 
Language II realizing a trading strategy. The 
advisor has an access to the trading terminal data 
and can deal automatically. 
You can 'Create a new Expert', 'Delete', 

'Modify', or Attach to a Chart. 
When creating a new expert or modifying an existing expert, the MetaEditor will appear.  
If the experts' items are red they are not allowed for demo trading. Please contact your sales 
representative for further assistance.  

Terminal 
 
The 'Terminal' window can be enabled/disabled from the main menu ('View - Terminal'), by pushing the key

'Ctrl - T' or by clicking the button of the 
The information shown in the terminal is grouped into several sections: 

Trade 
 

 
 
In the 'Trade' section, you can find your current account status including open positions and pending orders.  



 

The following clauses are available in the contextual menu:  
•  New order - open the dialogue box for setting the orders;  
•  Modify or Delete Order - modify the levels of 'Stop Loss' or 'Take Profit', 
level of the 'Pending Order', delete the pending order;  
•  Trailing Stop - change the Trailing Stop level. Select the value of Trailing Sto
to 80 pips) in the sub-menu, or 'None' to deactivate the Trailing Stop funct
selected order, or 'Delete All' to deactivate the Trailing Stop function for all order
•  Auto Arrange - automatic setting of the columns when changing the tradi
window size;  
•  Profit as Points - show the profit/loss in pips or in dollars;  
•  Show on the Charts - show/hide levels of the open positions, pending orders,
chart;  
•  Comments - show/hide the 'Comments' column;  
•  Grid - show/hide the grid to separate the columns from each other.  

 
News 

 

 
 
News can be read by double clicking on the headline or by selecting the 'View' menu item.  
•  Auto Arrange - automatic arrangement of the column size when changing the trading terminal window size;  
•  Grid - show/hide the grid to separate the columns from each other. 
 

Account history 
 

 
 
The list of the deals made on the current account is placed In the 'Account history' 
section.  



 

Using the contextual menu you can filter the list of operations. 
•  All History;  
•  Last 3 Month;  
•  Last Month;  
•  Last Week;  
•  or only Today`s history can be shown;  
•  The current list can also be stored on the hard disk as a report in 
HTML format with the aid of contextual menu ('Save as Report');  
•  Auto Arrange - automatic arrangement of the columns when the 
trading terminal window size is changed;  
•  Comments - show/hide the 'Comments' column;  
•  Grid - show/hide the grid to separate columns from each other.  

 
Alerts 

 

 
 
The list of the defined signals is in the 'Alerts' section. Having defined the signal, a trader 
can easily leave the monitor. The WindowsTrader will alert the trader by giving out a 
sound signal or by realizing an .exe file that some condition was performed.  

 

The contextual menu includes the following clauses: 
•  Create a new Alert;  
•  Modify already existing alert (same as double clicking on alert):  
•  Delete existing alert;  
•  Freeze/Unfreeze - the same as on/off alert;  
•  Auto Arrange - automatic arrangement of the column width;  
•  Grid - show/hide the grid to separate columns from each other.  

 
You can indicate any file type registered in Windows (wav, exe, etc.) as an event for alert 
to react.  

 

• Symbol - instrument;  



• Condition - (time, bid<, bid>, ask<, ask>);  
• Value - relates to the condition;  
• Event - event which will happen in the case of performing the condition;  
• Enable - enable/disable the alert.  

Mailbox 
 

 
 
The list of all messages appear in the 'Mailbox' section. You can also view the content of 
the message by double clicking the left mouse button on the selected message. 

 
 

Journal 
 

 



 
The list of user and client terminal actions fixed during the current session is in the 
'Journal' section. Deals, the used advisor experts, information on their operation, and 
information on the operation of the client terminal are all fixed. 

Chart Setup 
 
 
 
The chart menu includes:  

• Indicators - opening the window of 'Indicators';  
• Expert Advisor - the menu of the lower level will appear 

where you can change the settings ('Properties...'), 
delete ('Remove') or test the history ('Test Strategy') 
of the expert attached:  
 

 

• Periodicity - selecting the periods of time for the chart;  
• Template - the menu of the lower level will appear 

where you can load a pre-saved chart template (settings 
and indicators) ('Open Template') or save the chart 
settings as a template ('Save Template'): 
 

 

• Refresh - the menu of the lower level will appear where 
you can both refresh the chart ('Refresh') and refresh 
the chart with simultaneous erasing of the local quotes 
base (the new quotes base to be downloaded from the 
server) ('Erase & Refresh'):  

 

• Auto Arrange - arrange indicators in the chart; 
• Grid - show/hide the grid in the chart;  
• Volumes - show/hide the chart of volumes;  
• Zoom In - enlarge the chart;  
• Zoom Out - miniaturize the chart;  
• Delete Indicator - (active only when the mouse clicked 

on the indicator shown under the price chart);  
• Save as - save the chart in the disk in the selected 

format (*.CSV,*.PRN,*.HTM);  
• Print Preview - preview before printing;  
• Print - print the chart;  
• Properties.. - different windows will be shown depending 

on the point where the mouse clicked:  



1. When clicking in the empty space of the chart:  

 

 
You can choose between three standard color schemes in this window by selecting the 
'Scheme' value, or you can set the chart colors according to your taste:  

o Background - the background color;  
o Foreground - the color of time scale and that of price scale;  
o Volume - the color of the volume chart;  
o Grid - the grid color;  
o Graph - price charts color.  

 

2. When clicking in the chart in a separate field with the indicator enabled:  
 
Window with settings of this Indicator setup will appear.  

Hot keys to work at the chart window:  

• cursor arrows Left and Right arrows - scroll the chart to the right and to the left;  
• Home and End allow to move to the beginning and to the ending parts of the chart;  
• '+' and '-' - will enlarge or miniaturize the chart;  
• Alt+1 - show the chart as Bars;  
• Alt+2 - show the chart as Candelsticks;  
• Alt+3 - show the chart as Lines;  
• Ctrl+G - grid on/off;  
• Ctrl+L - volume on/off;  
• Ctrl+A - auto arrangement of indicators;  
• Ctrl+I - open the window of indicators;  
• Ctrl+S - save the chart in the selected format (*.HST,*.CSV,*.PRN,*.HTM);  
• Ctrl+P - print chart in black-white colors;  
• Delete - delete the last added object in the chart;  
• Backspace - deleting the last added object;  
• F7 - opens the window of the active expert setting;  
• F8 - opens the window of the chart or indicator setting.  



How to work on the chart using your mouse:  

• you can move the chart in different directions by clicking the left mouse button and 
moving it horizontally;  

• you can change the vertical scale of the chart by clicking the left mouse button in the 
chart price field and moving it vertically;  

• you can change the horizontal scale of the chart by clicking the left mouse button in 
the chart date field and moving it horizontally;  

• you can open the contextual menu by clicking the right mouse button on the chart;  
• you can select an object by double clicking the left mouse button on it (trend, line, 

symbol, fibonacci);  
• you can edit the selected object by clicking the left mouse button on the selected 

object and then moving it;  
• Ctrl + clicking the left mouse button on the selected trend with the following moving 

of it allows to create a parallel trend;  
• you can open the object setting window by clicking the right mouse button on the 

selected object.  

Charts bar  
 
The 'Charts' bar is made as a floating window which can be attached to the left, right or low 
margin of the program window. 

 
 
Using the 'Charts', you can:  

• Change the chart type for: 

- Bar; 

- Candelesticks; 

- Line;  

• - Zoom in;  

• - Zoom out;  

• - Open the template by default (chart settings and indicators set);  

• - save the template by default (chart settings and indicators set);  

• When the button is clicked after a new quote has come, the chart will be 
automatically replaced to the left to such extent that the chart right margin can be 
seen well;  

• When the button is clicked, the right margin of the chart is not attached to the 
right side of the window, but it is in the middle of the window;  

• The clicked button allows usage of the Expert Advisor.  

Graphical instruments 
 
You can add different symbols and lines to the chart. You can use the 'Insert' menu or 
buttons of the bar to add lines and symbols. You can delete lines and symbols one by one by 
using the 'BackSpace' button or by the 'Charts' menu. You can also delete all the lines and 
symbols by the 'Charts' menu. To edit the objects you should select by double clicking the 
mouse, click the right mouse button, and select 'Properties' (the selected object can also be 



moved and deleted out of turn). The selected objects can be moved independently from each 
other. The 'Line Studies' bar is performed as a floating window which can be attached to the 
left, right or low margin of the program window.  

 
 

- the 'Crosshair' allows to position the mouse cursor exactly in the chart. You can add the 
following elements to the chart using the 'Line Studies' bar: 

- Vertical Line; 

- Horizontal Line; 

- Trend Line; 

- Andrews` Pitchfork; 

- Gann Fan; 

- Fibonacci Fan; 

- Fibonacci Arcs; 

- Fibonacci Retracement; 

- Symbols; 

- Text. 
 
To add a vertical or horizontal line, select the corresponding button of the 'Line Studies' bar 
and click the left mouse button at the desirable place in the chart. To add the trend line or 
Fibonacci retracement select the corresponding button of the 'Line Studies' bar, then click the 
left mouse button (and do not leave it) at the first point of the trend (at the point of the start 
moving for retracement), move the cursor to the second point of the trend (to the point of 
stop moving for retracement) and leave the left mouse button. To make the canal line, push 
Ctrl + click the left mouse button at the selected trend. Move the mouse without leaving 
the button on it. A new trend parallel the selected one will follow the cursor. To add the 

symbol you should click the button . An auxiliary menu will appear:  

 
 
Select the desirable symbol. Then click at the desirable place of the chart. 
To add the text in the chart:  

• Click the button ;  
• Click in the desirable place of the chart;  
• Double click the appeared inscription 'Text', the outline around the inscirption will 

appear;  



• Click the right mouse button above the inscription and select the 'Properties...' in the 
menu : 

 

 

• Edit the inscription properties and press 'OK';  
• Double click the mouse to unselect it. The outline should disappear.  

Indicators 
 
You can add technical indicators to the chart using the 'Navigator' window, or indicators 
window (menu 'Insert -> Indicators', 'Ctrl+I').  

 
 
All indicators are in the 'Available' group, and those you want to see in the chart are in the 
'Selected' group. To add an indicator to the chart, select it in the 'Available' group and click 

the button. The indicator will appear in the 'Selected' group. After the indicators window 
has been closed this indicator will appear in the chart. To delete an indicator from the chart 

select it in the 'Selected' group and click the button. The indicator will disappear from the 
'Selected' group.  
 
When using the same set of indicators, you can use the 'Template': having set a complex of 
indicators in one chart, select 'Template -> Save Template' in the 'Charts' menu or in the 
contextual menu. To use the saved set of indicators in another chart, select 'Template -> 
Open Template'. After the indicators window has been closed, it will disappear in the chart, 
as well.  
 
Indicators available in WindowsTrader:  



• Accumulation/Distribution;  
• ADX;  
• Average True Range;  
• Bollinger Bands;  
• Commodity Channel Index;  
• DeMarker;  
• Elder-rays;  
• Envelopes;  
• Force Index;  
• Ichimoku Kinko Hyo;  
• MACD;  
• Market Facilitation Index;  
• Momentum;  
• Money Flow Index;  
• Moving Average;  
• Moving Average of Oscillator;  
• On Balance Volume;  
• Parabolic SAR;  
• Relative Strenght Index;  
• Relative Vigor Index;  
• Stochastic Oscillator;  
• Williams' Percent Range;  
• Williams' Alligator;  
• Awesome Oscillator;  
• Accelerator/Decelerator Oscillator;  
• Fractals; and  
• Gator Oscillator.  

Experts 
 
    'Expert Advisors' are used to automate the trading process. Many professional traders 
have a big amount of trading systems allowing them to work in different markets and under 
different conditions.  
 
    Expert Advisors sends signals generated by trading systems to a trader's real account to 
manage open positions, orders and stops. 

 
Opening Positions and Pending Orders 

 
Opening of a position or setting a pending order can be performed several ways:  

• 'Tools -> New Order' in menu or 'F9';  
• double click at the exchange rate in the 'Market Watch' window;  
• right click on the trading 'Terminal' window (the 'Trade' section) and select the 'New 

Order'.  

The dialogue box will appear which can help to open a position or to set a pending order: 



 
 
You can select an instrument (the 'Symbol' field) or a number of lots (the 'Lots' field). The 
number of lots may represent a fractional number having a step of 0.1, but not less then 
minimum contract.  

 
 
After having dealt you will see the open position in the trading 'Terminal' window. If the 
current market prices do not satisfy your needs you can set a pending order. A Pending order 
is an order to buy or to sell a certain amount of lots at a certain price when the market 
reaches this certain price. To set a pending order you should fill in the fields 'Type' (order 
type), 'At price' (order price), 'Symbol' (instrument) and 'Lots' (the number of lots).  



 
 
Rules of pending orders setting:  

 
 
Then click the 'Send' button. Information about the trade will appear in the trading 'Terminal' 
window. If your pending order parameters were incorrect the message 'Invalid Price' will 
appear. This means you are trying to set the order too close to the current price (closer than 
the spread value for this instrument), or you have selected a wrong order type ('Buy Limit, 
Buy Stop, Sell Limit, Sell Stop'). As a separator for the whole and fractional parts of the lot 
size you should use a DOT, not a comma. When opening a position and when setting a 
pending order, you can set Stop Loss and Take Profit at once. You can do it by filling in the 
fields 'Stop Loss' and/or 'Take Profit' (before clicking the 'Request' or 'Send' button). You 
can change the level of a pending order in several ways:  

• Click on the window (the 'Trade' section) and select 'Modify or Delete Order' in it;  
• Make a double click on the pending order in the trading terminal window.  

The window will appear:  



 
 
Set a new level of the order in the 'Price' field and click the 'Modify' button. 

Closing Positions and Deleting Pending Orders> 
 
To close a position, you should double click on the open position in the trading 
'Terminal' window. The window will appear: 

 
 
If you just want to close a position at the current price click the 'Request' button. A 
price will appear in several seconds allowing you to fully or partly close the position:  



 
 
If the price is reasonable, click 'Close #... .. at ...' (in our example: Close #345960 
buy 1 EURUSD at 1.0987). The number of lots can be fractional having a step of 0.1, 
but not less than the value of the minimum possible lot. If, after partly closing the 
position, the client trading under the FOREX conditions has an open position with a 
value under the minimum contract value, the client must close such position 
afterwards. A broker has the right (but is not obliged) to decline the client's request 
for partly closing the position. When closing a position for which there is one or 
more opposite positions among the open positions (i.e., for a position open for 
buying - one or more positions for selling, and vice versa) for the same instrument, 
the client has an opportunity to close this position by simultaneouly closing the 
opposite position. To do so, you should click the 'Close # ... by ...' button (in our 
example: Close #346028 by ...), having pre-selected a counter-position in the right 
list. Here, if the counter-position has the same value as the position being closed, 
both positions will be closed, and the financial result of the operation will be defined 
by the difference between the opening rates multiplied by the value of the closing 
position and the one pips value for one lot. If two counter closing positions have 
different values, the value of the smaller of two counter positions will be considered 
to define the financial result, and the position will stay in the market which was 
opened in the direction of the larger (in value) position, the value of which is defined 
as the difference in values of these two positions. Note that after clicking the 
'Request' button and receiving the Bid/Ask quotes, the buttons 'Buy' or 'Sell' will 
also become active. You can open a new buying position having clicked the 'Buy' 
button, or you can open a selling position having clicked the 'Sell' button. You can 
delete a pending order in several ways:  

• double click the mouse on the pending order in the trading 'Terminal' 
window;  

• select a pending order in the trading terminal window and click the right 
mouse button. Select 'Modify or Delete Order' in the contextual menu 
appeared.  

After performing any of these actions you will see the window:  



 
 

 
 
To delete a pending order click the 'Delete' button.  

Setting, Editing and Deleting StopLoss and TakeProfit orders 
 
To set 'Stop Loss' and 'Take Profit' orders on an open position, select the open position and 
click the right mouse button. Select the 'Modify or Delete Order' button and the following 
window will appear: 

 
 
Set the necessary order levels ('Stop Loss' and 'Take Profit' fields) and click the 'Modify' 
button. When setting orders use a period, not a comma, to separate whole and fractional parts 
of the numbers. If you receive a message 'Invalid stops' when setting an order it means the 
order was set too close to the current price, a comma was used to separate the whole and the 
fractional number, or Stop and Take Profit were backwards. To delete values of Stop Loss or 
Take Profit for the order set it at 0.0000. To set 'Stop Loss' and 'Take Profit' orders in a 
pending order click the right mouse button and select 'Modify or Delete Order'.  

 
 
Set the necessary order levels (the 'S/L' and 'T/P' fields) and click the 'Modify' button. To 
delete a 'Stop Loss' or 'Take Profit', set it at 0.0000. 

Export quotes via DDE 
 
You can export the data into external programs in realtime via the DDE (Dynamic Data 



Exchange) protocol. You should select 'Tools -> Options -> Server -> Enable DDE' from 
the menu to activate quotes exporting from WindowsTrader by the DDE protocol. 

 
 
Format of DDE requests (example in c:\Program Files\WindowsTrader\DDE-sample.xls):  

• request BID: =MT|BID!USDCHF      result: 1.5773  
• request ASK: =MT|ASK!USDCHF      result: 1.5778  
• request HIGH: =MT|HIGH!USDCHF      result: 1.5801  
• request LOW: =MT|LOW!USDCHF      result: 1.5741  
• request TIME: =MT|TIME!USDCHF      result: 21.05.02 9:52  
• request QUOTE: =MT|QUOTE!USDCHF      result: 21.05.02 9:52 1.5773 1.5778 

1.5776  

Quotes archive 
 
The quotes archive can be activated from the main menu 'Tools -> History Center'.  



 
 
In the upper window, the list of instruments is shown on which there is a quotes history. The 
quotes histories come from server when opening the corresponding chart. When double 
clicking the mouse on any instrument in the lower window, the quotes list for this instrument 
will appear. This list (history) can be edited by using the buttons 'Add', 'Edit', 'Delete'. The 
data of the list can also be imported ('Import') and exported ('Export'). Files of the quotes 
histories having the names like SSSSSSPP.hst (where SSSSSS is the name of the instrument, 
PP is a period of time) are saved in the 'bases' directory. These files can be exceptionally 
useful when testing trading strategies.  
 


